Multiple Questions, 1911 Buick Model 26

Get help and help others restore and enjoy driving/touring in horseless carriages

Multiple Questions, 1911 Buick Model 26

Postby BuickMoose » Sun Mar 20, 2016 10:23 am

Hello All
New to me 1911 first Brass Car.

Got it running well this weekend, it suffered from sitting for 20 years.

Transmission: Looks like the PO put really thin oil in there, it leaks like crazy and it's almost impossible to get it in first when cold. No problem finding the proper oil, am going to need to flush it a few times, but want to make sure I'm doing it right. There are two drain plugs - one either end, and what looks like an overflow plug on the side. No easy place to put new oil in without removing the floorboards. I assume I fill it up until oil comes out the overflow, correct? Any ideas about how much it might hold? Ordered 6 quarts of oil.

Ignition. The Magneto doesn't seem right, it has three switch positions Run Off Bat but the car only runs in Off, found a modern 6v battery under the seat clumsily wired to a terminal on the magneto but it seems to serve no purpose whatsoever.

The distributor cap is on the aft end of the magneto, where might I find a new cap, rotor, and points? I'm sure they are in pitiful shape given what the plugs looked like.

That's all for now, I'm sure there will be more, Thanks for reading.

Alan
User avatar
BuickMoose
 
Posts: 1
Joined: Sun Mar 20, 2016 6:45 am

Return to Restoration Tips & Advice

Who is online

Users browsing this forum: No registered users and 2 guests

cron